Playback problem

Ask a question, or offer help to others
Post Reply
peterpiper
Posts: 3
Joined: Tue Feb 28, 2012 12:45 am

Playback problem

Post by peterpiper » Tue Feb 28, 2012 1:00 am

Have latest free version of Musette running with XP. After downloading latest windows update pack and several System Restores due to USB hub problems (now fixed), Musette appears to play back back but no sound is heard. All other audio is working normally. How can I find Musette's audio pathway to verify or modify settings?

maestro
Site Admin
Posts: 159
Joined: Tue May 01, 2007 9:06 am

Re: Playback problem

Post by maestro » Tue Feb 28, 2012 8:30 am

peterpiper,

Sorry about your computer problems. http://musettemusic.com/help.php has a couple files to help diagnose the problem. First try "AntMarch.mid". If that doesn't play, download and run "MidiDev.exe" which displays the installed midi devices. Musette plays through the midi mapper. You can check settings through control panel. If you need more help, include the output of MidiDev.exe in your next post. Click "File/clipboard" to paste the information to the windows clipboard.

peterpiper
Posts: 3
Joined: Tue Feb 28, 2012 12:45 am

Re: Playback problem

Post by peterpiper » Tue Feb 28, 2012 6:18 pm

Many thanks for your answer, but no joy yet.
AntMarch.mid plays fine. Here is the MidiDev result:

Name Microsoft MIDI Mapper, vendor 1, product 1, tech Mapper, voices 0, notes 0, channels FFFF, support Stream
Name Juli@ MIDI, vendor 1, product 102, tech MIDIPort, voices 0, notes 0, channels FFFF, support
Name MPU-401, vendor 1, product 102, tech MIDIPort, voices 0, notes 0, channels FFFF, support
Name Microsoft GS Wavetable SW Synth, vendor 1, product 102, tech SWSynth, voices 48, notes 48, channels FFFF, support LRVolume/Volume

In Control Panel/Sounds and Audio Devices/Audio/MIDI music playback Default Device, I have Juli@MIDI (my sound card) selected and the options MPU-401 and Microsoft GS Wavetable are also there. Microsoft MIDI Mapper is not there, and I have no idea how to find it. "Use only default devices" is unchecked.

Cheers

maestro
Site Admin
Posts: 159
Joined: Tue May 01, 2007 9:06 am

Re: Playback problem

Post by maestro » Wed Feb 29, 2012 9:02 am

Let's backup. Stop me if I get anything wrong.

1) Musette V2.11.5 played normally before installing Windows XP Service Pack 3
2) The Juli@ and MPU-401 midi devices were installed when it worked
3) System Restore only backed up to a time after you installed both MIDI devices
4) Volume is properly adjusted in Musette and Windows' "Master Volume"
5) You recognize the sounds of the various MIDI devices or are otherwise confident that when you play AntMarch.mid it actually played using the Juli@ device.

Midi Mapper is a virtual device that uses the default device set in Control Panel, in your case the Juli@ device. As far as I know, it doesn't appear in Control Panel as a separate device.

If you didn't play AntMarch.mid using Windows Media player, try that. As far as I know it uses the default device.

You probably got several programs with the MIDI device hardware. See if any of them allow selecting the MIDI device for playback. Make sure you can play on any of the installed devices, and if there's a "MIDI mapper" or "default" option, also try that. Make sure that it really plays using the selected device, perhaps by recognizing the sound or using an external speaker or earphones connected to the selected device.

peterpiper
Posts: 3
Joined: Tue Feb 28, 2012 12:45 am

Re: Playback problem

Post by peterpiper » Wed Feb 29, 2012 3:38 pm

Many thanks, again. With yr help, after looking closely at Control Panel/Sounds and Audio Devices/Midi music playback/ I found that, although my soundcard Juli@MIDI was set as default device, the volume control button was inactive (I had previously assumed that Juli@'s own volume control was all that was required). Changing default device to Microsoft GS Wavetable Synth gave an active Volume button: a click revealed volume at zero....another click.... Bingo! Musette working!

Post Reply